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IMPORTANT PRE 
TRAINING INFO
At City Desktop, we know that when you come to 

a training course you want an expert trainer with 

industry experience, who can provide you with 

not just the basics but also lots of tips, tricks and 

helpful hints and who can also share with you 

best workflow practices. 

We also know that at the end of training you 

want to feel confident that you can implement 

what you have learnt and to create documents in 

the most efficient manner possible.

Ensuring you meet the course pre-requisites and 

have read through the required reading material 

PRIOR to course commencement, helps us to 

deliver these outcomes and allows you and fellow 

course participants to get the maximum benefit 

from your training experience.

Please also be aware that while we endeavour to 

make sure all students meet the prerequisites, 

there sometimes are a few people faster and 

a few people slower than the majority in any 

computer course. We endeavour to pace the 

course at a ‘medium’ speed based on the 

thousands of public courses run to date. If you 

want training exactly at your own pace, then 

organizing private training might be a better 

option for you.

PRE-REQUISITES 
To use Premiere Elements effectively, it is 

required to cover a fairly large area to ensure 

best practices. Previous experience is not 

required, however, you will require to know 

and be comfortable with the standard generic 

practices and shortcuts that are found throughout 

Adobe’s Creative Suite.

This document has been created so you can 

arrive at your training confident in the basics and 

ready to tackle all Premiere Elements has to offer. 

Throughout this document you will find a variety 

of reading material and video tutorials that will 

ensure you are prepared to get the most from 

your upcoming training with us at City Desktop 

Training.

CONTACT & LOCATION 
DETAILS
Training Rooms: 

SYDNEY: Level 5, 89 York Street 

MELBOURNE: Cliftons, 440 Collins Street 

BRISBANE: Cliftons, 288 Edwards Street 

Classes begin at 9am, and students need only 

arrive 10 to 15 minutes prior.

Phone: 1300 441 8911   

Email: info@cd.com.au



TASK PANEL 
OVERVIEW
The Adobe Premiere Elements workspace is 

optimized for organizing media, editing and 

sharing movies, and creating menus for DVDs 

and Blu-ray Discs. You can customize the 

workspace to suit your needs. Adobe Premiere 

Elements combines everything you need to 

create a movie, including video, audio, effects, 

transitions, and titles, into a single file called a 

project file. 

•	 �The Adobe Premiere Elements workspace 

is optimized for the four major phases of a 

project: organizing footage (video, stills, and 

audio), editing a movie, creating menus for 

DVDs and Blu-ray Discs, and sharing movies. 

•	 You can easily change from one task to the 

other by choosing different task-based buttons 

in the Tasks panel. As you change tasks, the 

workspace displays the appropriate panels and 

panel views. 

•	 You can also customize the workspace 

to meet your specific needs by adding and 

arranging panels.

•	 Drop zones are areas in the workspace onto 

which you can drop or move panels. As you 

drag a panel, underlying drop zones become 

outlined. The highlighted drop zone shows 

where the panel will be inserted into the 

workspace. Dragging a panel to a drop zone at 

any of the edges of a panel results in docking.

•	 Note: To see the names of panels in the 

workspace, choose Window > Show Docking 

Headers.

Edit workspace displaying Effect Properties view



PROJECT VIEW 
OVERVIEW

•	 The Project view lets you preview source 

material for your projects. To access the 

Project view, select Window > Available Media 

or Organize > Projects.

•	 In Project view, you can display items in 

either List view or Icon view. List view lets 

you view more items simultaneously and sort 

items by properties such as media type and 

duration. Icon view displays thumbnails that 

let you visually organize project contents.

•	 To change the view, click the List View 

button  or the Icon View button  at the bottom 

of the panel. Alternatively, right-click in the 

Tasks panel, and choose View > List or View > 

Icon.

•	 To arrange items in Icon view, drag an item 

to any square. As you drag, a vertical bar 

indicates where the item is going. If you drag 

an item to a folder, the item goes inside the 

folder.

•	 To sort items in List view, click the column 

heading by which you want to sort the items. 

(For example, click Media Type to sort items 

by type.) If folders are expanded, items sort 

from the top level and down the Project view 

hierarchy. To reverse the sort order, click the 

column heading again.

•	 To see more of the column headings in List 

view, drag the right side of the Tasks panel to 

the right to resize it. Or drag the scroll bar at 

the bottom of the panel to the right.

Work space: Project view 

A. Show video B. Show audio C. Show still images D. New item E.Folders F.Clip thumbnail G. List view H. Icon 

view I. Move up a level J. New Folder K. Clear



WORKSPACES: 
Organize
The Organize workspace displays thumbnails of 

all the media (videos, still images, and audio) 

that you’ve imported into Adobe Photoshop® 

Elements® or Adobe Premiere Elements. You can 

access and share all the files in the Organizer 

seamlessly between the two applications.  From 

the Organize workspace in the Tasks panel, you 

can access the following:

Get Media

Lets you add files from various sources including 

video cameras, webcams, digital still cameras, 

WDM devices, mobile phones, and folders on 

your hard disk.

Media

Displays the thumbnails of all media files.

Instant Movie

Automatically and quickly steps you through the 

selection and editing portion of movie creation, 

adding theme-based effects, titles, transitions, 

and audio. You can change settings as desired.

Organizer

Launches the Elements Organizer window where 

you can import, view, find, organize, and manage 

media files.

Project

Displays the details of all media files.

Organize Workspace



WORKSPACES: 
Edit
When you’re ready to arrange or edit your media, 

click Edit in the Tasks panel. The Edit workspace 

lets you add movie themes and templates to your 

movies, apply effects and transitions, and create 

and add titles. In addition, the Properties view 

appears within the Tasks panel when you choose 

Window > Properties or when you edit effects or 

transitions.

From the Edit workspace, you can access the 

following:

Effects

•	 Shows effects and presets you can use in your 

movie. You can search for an effect by typing 

its name into the search field. To see only 

specific types of effects, choose an option 

from the first menu: Video Effects, Audio 

Effects, Presets, My Presets, or Favorites. You 

can also view specific categories by choosing 

a category, such as Adjust or Channel, from 

the second menu (Show All is the default). To 

edit an effect before applying it, select it and 

click Edit Effects to open Properties view.

Transitions

•	 Shows transitions you can use in your movie. 

You can search for a transition by typing 

its name into the search field. To see only 

specific types of transitions, choose an option 

from the first menu: Video Transitions, Audio 

Transitions, or Favorites. You can also view 

specific categories by choosing a category, 

such as 3D Motion or Slide, from the second 

menu (Show All is the default). To edit a 

transition before applying it, select it and click 

Edit Transitions to open Properties view.

Titles 

•	 Shows pre-formatted titles you can use in 

your movie. To see only specific types of 

titles:

•	 Choose an option from the first menu, 

Entertainment, General, Happy Birthday, 

and so on. if you want to narrow the choices 

more, choose a specific theme, such as Blue 

Notes or Ladybug Picnic, from the second 

menu.

Themes

•	 Enables you to view Themes. Displays 

InstantMovie themes that instantly and 

dramatically enhance your movies. Themes 

make it easy to create professional-looking 

movie. They automatically edit your clips 

and apply effects, transitions, overlays, title 

and closing-credit sequences, videos, sound 

effects, and more. You can apply all the 

options in a theme, or choose the options you 

want.

ClipArt

•	 Displays clip arts that can be used in your 

video files.



WORKSPACES: 
Enhance & Share.
ENHANCE/Disc Menus workspace

When you’re ready to add menus to your movie 

for DVD or Blu-ray Disc, click Disc Menus in 

the Tasks panel. From this workspace, you can 

access your media and the menu templates.

Note: When you click Disc Menus in the Tasks 

panel, the Monitor panel switches to the Disc 

Layout view. Use Disc Layout view to drag-and-

drop templates and media to personalize your 

menus.

From the Disc menus workspace, you can 

preview and choose preformatted templates you 

can use for menus. To see only specific types of 

templates, choose an option from the first menu: 

Entertainment, General, Happy Birthday, and so 

on. If you want to narrow the choices, choose a 

specific theme.

SHARE WORKSPACE

When you’re ready to burn a disc, or save your 

movie for viewing online or on a mobile phone, 

PC, videotape, or other device, click Share in 

the Tasks panel. This workspace provides all the 

tools necessary to save your file for sharing with 

others.

Use Quick share to create and reuse preset 

sharing options, making sharing quick and easy. 

For example, if you frequently share projects 

by burning them to DVD, set up your optimal 

settings for burning a DVD, and save those 

settings as a Quick share. The next time you 

want to burn a project to DVD, use the Quick 

share preset you created instead of setting all the 

DVD options again.

About projects
Adobe Premiere Elements creates a project file 

for every new project you start. By default, a 

project preset is used for the television standard 

(NTSC or PAL) you selected when you installed 

the program.

A project file stores only title files and references 

to the source files that you capture or import, 

so project files remain fairly small. Because only 

references to the source files are stored, avoid 

moving, renaming, or deleting your source files 

so that Adobe Premiere Elements can continue to 

locate them.

You can create a project on your own by adding, 

arranging, and editing your media, and then 

adding transitions, effects, and titles; or you can 

create an InstantMovie project. InstantMovies 

step you through the process of adding your 

media from the Organize workspace, choosing 

a theme for your movie, and customizing any of 

the theme options, such as title and credits text, 

and background audio. Adobe Premiere Elements 

then analyzes and arranges your footage in the 

Timeline, adds transitions, titles, and audio, 

and then lays it out on the Sceneline so you 

can preview it and save it in the format of your 

choice.

Start a new project
When you start a new project or an InstantMovie 

project, you can review the default preset and its 

settings by clicking the Change Settings button. 

Make sure that you are using a preset that uses 

the same specifications of your source media.

Important: Some settings, such as frame rate, 

size and aspect ratio, can’t be changed after 

a project is created—verify all project settings 

before starting a project. Using the wrong project 

settings can adversely affect performance as you 

work on your project.



By default, the folder for a saved project also 

stores rendered previews, conformed audio files, 

and captured audio and video. These files are 

very large, so save them to your largest, fastest 

hard drive. To store these files separately from 

projects, choose Edit > Preferences > Scratch 

Disks.

1. Do one of the following:

From the Welcome screen, click New Project.

If Adobe Premiere Elements is open, choose File 

> New > Project.

2. (Optional) To change the settings used, click 

Change Settings, select a different preset and 

click OK.

3. In the New Project dialog box, specify a name 

and location for the project, and click OK.

Open a project
You can open only one project at a time. To 

ensure that Adobe Premiere Elements can open 

an existing project, make sure that both the 

project file (.prel) and the source files used in it 

are accessible on your computer.

Do one of the following:

From the Welcome screen, click Open Project, 

and then click the project name. (If the project 

isn’t listed, click Open, select the project file, and 

click Open.)

If Adobe Premiere Elements is open, choose File 

> Open Project or Open Recent Project; then 

select the project file, and click Open.

In Windows®, double‑click the project file.

Note: Adobe Premiere Elements can open 

projects made in earlier versions of the program, 

but earlier versions of the program cannot open 

projects made in later versions. If you have two 

or more versions of Adobe Premiere Elements 

installed, you may need to open a project from 

within the software, or by right-clicking the file 

and choosing the application, rather than by 

double‑clicking the project file.




